Forum Index Gameplay Help and Discussion PoE-ItemInfo Script (Version 2.3+)

History

"
aRTy42 wrote:
"
ThorTheGray wrote:
aRTy thank you very much for taking over the work on this script! I bumped the old thread a bit in hopes someone would step up. Glad you did!


Anyone know how we get the link on reddit updated to point to this thread?


I considered it right away when I saw Bahnzo leaving, but when I took a closer look and noticed the unique-data-script wasn't working anymore due to a change in the wiki and that I wouldn't be able to easily fix it (coded in python), I didn't feel up to taking over. After the script was fixed by someone else, I thought I could get along with the AHK coding, so that was the crucial point. Also, I now know a few people to directly ask for help.

About the Reddit link:
Good thing you mention it. I didn't think of it. I'll contact the mods.


Edit:
I also love the new thread ID: 1 678 678. Even though it is almost irrelevant, it's so catchy.


That is why I love this community, people stepping up to help each other. I also looked at the coding of the script myself however I have never written script before but I always like the challenge of learning something new. After looking at it I was more lost than I was when I started playing PoE lol.

Again, thanks for taking things over!

ThorTheGray
Jun 12, 2016 15:26:13 PM

Thank you for doing this.

Aalhamas
Jun 12, 2016 18:46:46 PM

Hey guys,

Quick question. Has anybody else been getting an error message when running the script? This script worked fine on my old PC, as well as all my other scripts. I purchased a new rig for the launch of Prophecy and now this script is no longer working. All my others are working fine. If anyone knows how to fix this, please let me know.

Error message: Error at line 144.

Unfortunately, Windows 10 on the new PC.

Thanks in advance.

PhailSauce
Jun 13, 2016 13:11:49 PM

"
PhailSauce wrote:
Hey guys,

Quick question. Has anybody else been getting an error message when running the script? This script worked fine on my old PC, as well as all my other scripts. I purchased a new rig for the launch of Prophecy and now this script is no longer working. All my others are working fine. If anyone knows how to fix this, please let me know.

Error message: Error at line 144.

Unfortunately, Windows 10 on the new PC.

Thanks in advance.


Without any additional info other than new win 10 OS my best bet is you didn't run it as admin

EDIT: Noob me, didn't see the error message you posted
Can't check now as I'm not on my pc atm
Perhaps someone can check that line for you.
Still run it as admin and perhaps redownload the whole thing

happylittletree
Jun 13, 2016 16:56:41 PM

"
PhailSauce wrote:
Hey guys,

Quick question. Has anybody else been getting an error message when running the script? This script worked fine on my old PC, as well as all my other scripts. I purchased a new rig for the launch of Prophecy and now this script is no longer working. All my others are working fine. If anyone knows how to fix this, please let me know.

Error message: Error at line 144.

Unfortunately, Windows 10 on the new PC.

Thanks in advance.


line 144 is : #Include %A_ScriptDir%\data\Version.txt
so it seems you are missing the version.txt file in the data directory.
You can either create a file named Version.txt in the data directory(in the folder where the script is) and edit the version file so it contains those two lines and save it

ReleaseVersion := "2.3.02"
AHKVersionRequired := "1.1.05"

or redownload the 2.3.02 script file which contains that version.txt file

good luck and good drops !

Sundrino
Jun 13, 2016 18:40:31 PM

"
PhailSauce wrote:
Hey guys,

Quick question. Has anybody else been getting an error message when running the script? This script worked fine on my old PC, as well as all my other scripts. I purchased a new rig for the launch of Prophecy and now this script is no longer working. All my others are working fine. If anyone knows how to fix this, please let me know.

Error message: Error at line 144.

Unfortunately, Windows 10 on the new PC.

Thanks in advance.


If it is not fixed yet:

1) Get a recent version of autohotkey. If you installed one in the last few weeks (because your PC is setup new entirely), skip that. If you kept your harddrive and did not install fresh, definitely get autohotkey again.

2) Once you've downloaded the PoE ItemInfo script:
> Don't try to run the script while the whole thing is still zip'ed up. Extract the zip so you get a regular folder.
> Don't move just the .ahk file. The script needs the whole folder.
> Put the whole folder wherever you like, but don't split things up. If you want to start the script from the desktop or something but don't want the folder there, then create a shortcut to the .ahk file and put that shortcut on your desktop.

aRTy42
Jun 13, 2016 21:58:18 PM

"
aRTy42 wrote:
"
PhailSauce wrote:
Hey guys,

Quick question. Has anybody else been getting an error message when running the script? This script worked fine on my old PC, as well as all my other scripts. I purchased a new rig for the launch of Prophecy and now this script is no longer working. All my others are working fine. If anyone knows how to fix this, please let me know.

Error message: Error at line 144.

Unfortunately, Windows 10 on the new PC.

Thanks in advance.


If it is not fixed yet:

1) Get a recent version of autohotkey. If you installed one in the last few weeks (because your PC is setup new entirely), skip that. If you kept your harddrive and did not install fresh, definitely get autohotkey again.

2) Once you've downloaded the PoE ItemInfo script:
> Don't try to run the script while the whole thing is still zip'ed up. Extract the zip so you get a regular folder.
> Don't move just the .ahk file. The script needs the whole folder.
> Put the whole folder wherever you like, but don't split things up. If you want to start the script from the desktop or something but don't want the folder there, then create a shortcut to the .ahk file and put that shortcut on your desktop.


This worked, didn't take the whole file. Feel slightly stupid, but thanks a lot for the help guys!

PhailSauce
Jun 14, 2016 06:05:31 AM

and thanks :)

4lin
Jun 15, 2016 13:10:23 PM

Hello

Sometime popup script auto show without press hotkey.

How to fix it ?

See picture

Spoiler



Thank you.

stepsamza
Jun 16, 2016 08:51:16 AM

"
stepsamza wrote:
Hello

Sometime popup script auto show without press hotkey.


Which version are you using?

Are you using any other scripts/tools for PoE?

Edit:
I contacted stepsamza ingame, we were not able to track down the cause of the pop-up behaviour, other than a guess that it might be related to tabbing out to the browser.

If anyone else encounters the same script anomaly, please report it here (in particular if it can be reproduced reliably).

aRTy42
Jun 16, 2016 09:33:15 AM
  • Prev
  • 1
  • 2
  • 3
  • 4
  • 37
  • 38
  • Next